/ninedogs.spec (e5b1512bd9c72e795882732ea82504110f268a96) (2276 bytes) (mode 100644) (type blob)
%{?systemd_requires}
Summary: Light and fast performance reporting and app tracing
Name: ninedogs
Version: 0.6
Release: 1
License: AGPLv3+
Group: Development/Tools
Source: http://kernel.embedromix.ro/us/ninedogs/%{name}-%{version}.tar.gz
URL: https://rocketgit.com/
BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
Provides: ninedogs
Conflicts: ninedogs
Requires: json-c, gnutls, libcap, catalinux+Conn, nginx-filesystem
Requires: libcurl
Requires: catalinux+stupidframework
BuildRequires: systemd-rpm-macros, json-c-devel, gnutls-devel, libcap-devel
BuildRequires: libcurl-devel, catalinux+Conn
# To generate the pdfs:
BuildRequires: texlive-latex, texlive-beamer, texlive-adjustbox
BuildRequires: texlive-babel-english, texlive-hyperref, texlive-url
BuildRequires: texlive-graphics texlive-extsizes
# For tests - TODO - postgres
# Seems is not available on RockyLinux 8!
#BuildRequires: mysql-connector-java
%description
Light and fast APM
%post
%systemd_post ninedogs-ingestd.service
%systemd_post ninedogs-webd.service
%systemd_post ninedogs-cert-notify.timer
%pre
getent group ninedogs >/dev/null || groupadd -r ninedogs
getent passwd ninedogs >/dev/null || useradd -r -g ninedogs -s /bin/bash -m -d /home/ninedogs -c "ninedogs user" ninedogs
%preun
%systemd_preun ninedogs-ingestd.service
%systemd_preun ninedogs-webd.service
%postun
%systemd_postun_with_restart ninedogs-ingestd.service
%systemd_postun_with_restart ninedogs-webd.service
%prep
%setup -q
%build
%configure
make
%install
rm -rf ${RPM_BUILD_ROOT}
mkdir -p ${RPM_BUILD_ROOT}
make install DESTDIR=${RPM_BUILD_ROOT}
%clean
rm -rf ${RPM_BUILD_ROOT}
%files
%defattr (-,root,root,0755)
/usr/share/ninedogs/*
%doc README LICENSE TODO samples
#%attr(0700,ninedogs,ninedogs) %dir /etc/ninedogs
/etc/nginx/conf.d/ninedogs.conf.sample
%config(noreplace) /etc/nginx/conf.d/ninedogs.conf
###%config(noreplace) /etc/ninedogs/config.php
###%attr(0700,ninedogs,ninedogs) %dir /var/log/ninedogs
%attr(0755,root,root) /usr/bin/*
%attr(0755,root,root) /usr/sbin/*
%{_libdir}/*.so
# This is for .service files
%{_unitdir}/*
%changelog
* Tue Oct 25 2022 Catalin(ux) M. BOIE <catab at embedromix dot ro> 0.6
Small things
* Fri Oct 21 2022 Catalin(ux) M. BOIE <catab at embedromix dot ro> 0.1
First try
Mode |
Type |
Size |
Ref |
File |
100644 |
blob |
177 |
5c4689cc689fe8331a251f33913b0450a47545e1 |
.gitignore |
100644 |
blob |
95 |
7642b9826e1e2c9b5c5c7aa9c940f97939d2571a |
History.txt |
100644 |
blob |
34520 |
dba13ed2ddf783ee8118c6a581dbf75305f816a3 |
LICENSE |
100644 |
blob |
783 |
70c9e3f19e0023cd079edde5ef8eba3ef692ca0e |
Makefile.common.in |
100644 |
blob |
1159 |
c23934f03cfbf5b90a1e6fcad3a8938830d71243 |
Makefile.in |
100644 |
blob |
42 |
d7c52ebbfd48ca77062939fdbb338cd89ec8c432 |
README |
100644 |
blob |
2544 |
27bab8edce282364523b15614e2c939d14d7de07 |
TODO |
040000 |
tree |
- |
76bbe1e93b0d0841617b1847f5453dbe0df14e4a |
agent |
040000 |
tree |
- |
e435d189f15c200328268ca93ba3a14c3c8b2331 |
common |
100755 |
blob |
30 |
92c4bc48245c00408cd7e1fd89bc1a03058f4ce4 |
configure |
040000 |
tree |
- |
1e5106b94ebd01f707f0ef0e2f62786ca4a026d5 |
debian |
040000 |
tree |
- |
f2fd66bde957d057a33dff00a5040166d4fb7a71 |
docs |
100755 |
blob |
18530 |
45f1710267130a4a4db542edd579f7c08be09839 |
duilder |
040000 |
tree |
- |
2383d9fa920eb5dda6d3f5eebee571ffc936e154 |
ingestd |
040000 |
tree |
- |
c0540001659e312c01c650f510e92b1a1b07e214 |
misc |
100644 |
blob |
2276 |
e5b1512bd9c72e795882732ea82504110f268a96 |
ninedogs.spec |
040000 |
tree |
- |
ed2ce950c8d76542b032c32b6414eb756393ae87 |
rocketgit |
040000 |
tree |
- |
6886f025e0842ae23d3f40ad0732c25d56007f2f |
samples |
040000 |
tree |
- |
1bc1c22f04695d14935ef117281aba60ce8b8ce4 |
test |
040000 |
tree |
- |
68c554b3cb25597390cbfd70c3ca9a16c7c265c8 |
tools |
040000 |
tree |
- |
4c377c29b3a8f5ebf62cfabf4563a1fec51e452b |
trace |
040000 |
tree |
- |
7f60f896e371d0e80536504788661c849c80b4fc |
webd |
Hints:
Before first commit, do not forget to setup your git environment:
git config --global user.name "your_name_here"
git config --global user.email "your@email_here"
Clone this repository using HTTP(S):
git clone https://rocketgit.com/user/catalinux/ninedogs
Clone this repository using ssh (do not forget to upload a key first):
git clone ssh://rocketgit@ssh.rocketgit.com/user/catalinux/ninedogs
Clone this repository using git:
git clone git://git.rocketgit.com/user/catalinux/ninedogs
You are allowed to anonymously push to this repository.
This means that your pushed commits will automatically be transformed into a
merge request:
... clone the repository ...
... make some changes and some commits ...
git push origin main